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1 Introduction 

The ElitePI® USB Transfer Utility is a tool that provides the ability to 
update collections, execute C.E. Electronics provided utilities retrieve 
collections and information, and set the time/date on an ElitePI.  This 
utility provides an alternative to the traditional ElitePI Transfer Utility that 
is connected to the ElitePI Communications Link.  It is possible, with this 
utility, to construct one installation package (Kit) on a USB Flash Drive 
(provided in this package) that will be able to update all the ElitePIs 
within a building or campus.  This makes it a very efficient mechanism to 
update displays where the ElitePI Communications Link is unavailable. 

2 Software Requirements 

Transfer Computer 
• Windows 98SE (Second Edition), Windows 2000 with SP3 or later, 

Windows XP 
• An available USB (version 1.1 or later) port on the computer 
• CD-ROM Drive 
• At least 128 MB of Ram 
• At least 10 MB of Disk Space 

ElitePI 

• ElitePI running version 1.69 or later of the Operating System. 

• Accessible USB Port on the ElitePI.  PLEASE NOTE:  USB port 
extender installation kits are available from C.E. Electronics. 

3 Installation Overview 

The installation process depends on the version of the operating system 
on the transfer computer and as well as the ElitePI.  For ElitePI OS 
versions between 1.69 and 2.0 it may be necessary to apply special 
updates to the OS.  Most units in the field have the proper drivers 
installed but some may require updating.  Contact a CE Electronics 
representative to determine if these special circumstances exist. 
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3.1 Installing the ElitePI USB Transfer Utility 

This only discusses the software installation on your computer.  Refer 
to the USB Hardware Upgrade Kit or the ElitePI installation guide for 
any hardware related instructions. 

3.2 Transfer Computer 

Steps 1: Insert the installation CD into the CD-ROM drive.  If your drive 
is setup in windows to automatically auto detect then the 
installation screen (Figure 1) will appear.  

 

Figure 1 - Main Installation window 

 If the installation screen does not appear then auto detect is 
disabled on your CD drive so it will be required to run the 
setup manually.  To do this use the start button and select the 
run option. 
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Figure 2 – Windows Taskbar Run 

  When the run window is open (Figure 2) press the BROWSE 
button and use the drop down to locate the CD drive.  Look in 
the root directory (Figure 2) of the CD and select setup.exe 
then press the OPEN button.  When returned to the run 
selection window press the OK button and the setup utility will 
execute.   When the installation window appears (Figure 1) 
you will be presented with 2 options to select from 

 
Installation Option Description 

Install Application Installs the USB Transfer 
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Install Time HASP 
Drivers 

If this option was purchased from C.E. 
Electronics then selecting this will 
install the USB Time HASP drivers.  
PLEASE NOTE:  If you have not 
purchased the Time HASP you 
should not install this option 

 

Step 2:  Select the options required for your installation.  Typically 
item 1 is the only one you would select 

 Only select option 2 if you purchased the Time HASP to 
update the ElitePI time and date. 

Step 3:  Once the options are selected press the INSTALL button 
which will begin the installation process. 

 Do not interfere with the installation process. 

 You will notice during the Time HASP driver installation that a 
prompt will occur at the end of the installation process.   
PLEASE NOTE:  Do NOT respond to the prompts, the 
installation utility will respond on your behalf. 

 When installation of the selected items is completed, the 
INSTALL button on the installation window will become 
active. 

3.3 Transfer Computers running Windows 98SE 

For Transfer Computers running Windows 98SE it will be necessary to 
obtain special USB Flash Drive drivers for the flash drive.  Contact a 
CE Electronics representative for an installation kit. 

3.4 ElitePIs before OS version 2.0. 

For those systems running the ElitePI OS before version 2.0, it may be 
required to apply some updates to the OS.  Please contact a CE 
Electronics representative to determine if it will be necessary to apply 
field updates to these displays. 
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3.5 ElitePIs running OS version 2.0 or later 

OS 2.0 and later is running the next generation OS and has complete 
support for both the USB Flash devices and the USB Time HASP.  No 
additional actions need to be taken. 

4 Quick Start Guide (Building Your First Kit) 

So now that all the software is installed it is time to build a Kit.  A Kit is 
the installation package you create (build) using the ElitePI USB Transfer 
Editor.   A Kit is what is executed on the ElitePI. 

This Quick start guide will teach you how to configure the editor for your 
ElitePI display environment, create a Task, apply a Task to a Kit then 
build a Kit onto a flash drive.  In this exercise, we will setup the ElitePI 
USB Transfer Editor and create a Kit to update a collection on a group of 
displays.  This is probably the most common task to be performed using 
this utility. 

4.1 What do you need to get started 

To prepare to use the ElitePI USB Transfer Editor it is necessary to 
have all the ElitePI physical addresses.  These should have been setup 
prior to the installation of your ElitePI(s) so these should be 
documented and readily available.  If this utility is an add-on to an 
existing ElitePI environment then it may be necessary to go to each 
ElitePI and update the physical addresses.  Both the High and Low 
address rotaries need to be adjusted.  Appendix A provides 
information regarding setting these addresses. 

To install a collection on the ElitePI, an updated collection will be 
needed that was updated using the ElitePI Design editor.  Make sure 
you know where the collection is saved on your computer.  You will 
also need the USB Flash Drive that was provided with this product. 

WARNING:   There are numerous Flash Drives on the market today 
but the ElitePI will only work with SPECIFIC ones.  Only use the 
Flash Drive provided with this product.  Using unapproved Flash 
Drives may cause the ElitePI to malfunction and may require it to 
be returned to the factory for repair. 
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4.2 Configuring the Editor 

There are 2 items that need to be setup in order to use the USB 
Transfer Utility.  These items are your ElitePI physical addresses and 
the Time HASP (if you purchased that option).  

To get the editor started, double-click on the desktop icon or by going 
to the taskbar and using the Start button: Start -> Programs -> ElitePI 
-> ElitePI USB Transfer.  Once the editor is started up you will be 
presented with a screen like shown in Figure 3. 

 

Figure 3 – ElitePI USB Transfer Editor 

4.2.1 Entering the ElitePI Display’s Addresses 

After the editor starts up, go to its menu bar and select Edit -> 
Displays.  The Display editor is presented (Figure 4) providing a grid 
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editor to enter information regarding each ElitePI.  The Grid editor 
presents 4 columns: 

 

Figure 4 – ElitePI Display editor 

 
Columns Description 

Name Unique, 20 character field that is the name you 
wish for ElitePI assigned. 

High 1 – 16 numeric value that describes the 
Physical High Address of the ElitePI 

Low 1 – 16 numeric value that describes the 
Physical Low Address of the ElitePI 

Description Verbose description of the ElitePI display 

 

The Grid editor acts similar to a spreadsheet that allows for tabbing to 
each column during data entry.  So start in the Name field by 
selecting that cell with your mouse and enter the name that you wish 
to assign to that ElitePI.  When finished use the tab key and move to 
the next cell to the right in the grid, which is the High Address cell.  
Enter the high address number.  Press the tab key again and enter 
the low address number.  Pressing the tab key again will place you in 
the description column where a verbose description of the ElitePI can 
be entered.  If more ElitePIs need to be added, pressing the tab key 
will open a new row and place you the Name cell of that row..  If any 
errors occur during cell editing they will be caught immediately when 
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moving to a different cell and a message will be displayed describing 
the problem.  You will be forced back into that cell to correct the error. 

If you wish to delete a display you can use the mouse drag and drop 
method.  Grab a cell in the row you wish to delete by placing the 
mouse pointer in the cell.   Press and hold the left mouse button down 
then drag it out of the grid.  Release the left mouse button on the 
window will cause the row to be dropped on the window and deleted 
from the grid.  If you are not mouse savvy you can simply select a cell 
in the row you wish to delete by placing the mouse pointer on that cell 
and pressing the left mouse button.  Once the cell is selected, press 
the DELETE button. 

To add a record to the grid with a lot of records you can press the 
ADD button, which will create a new row at the bottom of the grid and 
place you there. 

Once you are done entering car information you can press the OK 
Button to retain the display information entered.  This will return you 
to the main editor window where you can go to the menu bar and 
select File -> Save All to save your work thus far.  If you do NOT 
wish to retain the information you just edited press the CANCEL 
button on the window. 

The grid editor works the same for all the editing grids in the USB 
Transfer Editor.   So you can refer here if you have any problems 
using them. 

4.2.2 Setting the Time HASP Time and Date 

From the main menu select Edit->HASP.  The Time HASP editing 
window will be opened which is shown in Figure 5.  PLEASE NOTE:  
If the HASP option is grayed out (not selectable) then the Time 
HASP driver has not been installed. 
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Figure 5 – Time HASP configuration 

The first time you open this window a message stating that the Time 
HASP could not be located and an error stating that the HASP code 
needs to be entered will be displayed.  Press the OK button to 
respond to those errors.  Your Time HASP was provided to you with 
two password codes, enter them into the “HASP Code” boxes.  Insert 
the Time HASP into a USB port on your computer and wait for the red 
light to come on.  Press the FIND button on the Time HASP window.  
All the display boxes should go active and the current time/date on 
the Time HASP should be displayed.  If an error is displayed make 
sure the proper password codes have been entered and the Time 
HASP red light is on.  Correct the problem and attempt to find the 
Time HASP again. 

Probably the Time HASP time and date are not correctly set.  To set 
the time and match it to the current system time just press the SET 
button.  After a second or two the Time HASP time and date in the 
“HASP” boxes should closely match what is in the “Set To” boxes or 
be fairly close.  If you wish the time and date to a static value then 
uncheck the “System Time” checkbox.  Set the time and date to the 
desired values and press the SET button. 

There is a feature that allows you to stop the dynamic box updates for 
both the “Set To” and “HASP” boxes.  Press the STOP button will do 
this.  To reactivate the dynamic updating press the button again, 
which is now the START button. 
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The time and date on the HASP is now set, press the OK button to 
close the window and return you back to the main window.  Save the 
configuration data to the database by selecting the File -> Save All 
option. 

4.3 Creating and Editing a Task 

A Task is a group of instructions that can be executed on a group of 
ElitePI displays.  To edit a Task you first need to create one. 

   

Figure 6 –Tasks Grid 

On the main editor screen the top grid defines tasks (Figure 6).  There 
are 2 columns in the grid that need to be filled in, which are: 

 
Column Description 

Task Name 
Unique 20 character name for the task.  
Usually a building identifier or ElitePI display 
group is used here. 

Description 120 character verbose description of the task. 

 

Use the grid editor like you did when editing the ElitePI display 
information to create a Task.  You can go back later and create more if 
necessary but for now just do one so that you can understand how to 
setup a Task. 

After you have entered the Task header information it is always a good 
idea to save it.  Select File -> Save All in the bar menu to save all the 
data thus far 
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4.3.1 Editing a Task 

Now that a Task has been created it is now possible to edit the Task 
details.  To edit the Task that was just created, either double-click on 
the Task or single click on the Task then click the EDIT TASK button.  
You will be presented (Figure 7) with the Task Definition Screen.  
The window is rather busy but it is organized so that you can quickly 
select the items you wish to do to an ElitePI. 

The Task Definition screen is broken up into 4 sections.  On the 
upper left side are a number of checkboxes that allow you to select 
basic instructions to execute on the display.  These instructions 
include retrieving older collections from the ElitePI, displaying 
information regarding the time/date/panel address, rebooting the 
ElitePI, and retrieving the system logs.   

In the middle of the Task Definition window is the ElitePI time/date 
setting options.  Here one can set the time/date by the Time HASP, 
set the time and/or date to an absolute setting or if the ElitePI is 
ahead/behind by a certain number of minutes or days a time/day 
offset can be set. 

On the middle right side of the window, a collection can be selected to 
install or a C.E. Electronics provided program can be selected to be 
executed on the ElitePI. 
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Figure 7 – Task Definition Window 

On the bottom of the Task Definition window are the selection grids 
for which ElitePI displays that are available (left grid) and displays 
have been selected to execute this Task on (right grid) are shown.  In 
between the grids is a set of radio buttons that allows you to select if 
this Task is to be executed on “all” displays or “only on selected 
displays”.  When a new task is first created, the editor defaults to the 
“Only Specific ElitePIs” option. 

For this Task configuration example we are going to install an 
updated collection. 

Step 1: Press the SELECT button next to the “Collection to Install”.  
Click the button and locate the collection zip file.  Be careful 
to select an ElitePI collection.   If you do not select an 
ElitePI collection, it will be detected and an error will be 
displayed. 

 PLEASE NOTE: This is not a full proof method to test if 
a collection if valid so be cautious.  Most times it will 
catch a problem. 
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Step 2: Select which ElitePIs this collection is going to be installed 
on.  If it is going to be all of them then select the “All 
ElitePIs” radio button.  If it is only a select group then drag 
and drop the displays from the “ElitePIs Available” grid into 
the “ElitePIs Task to be Executed on” grid or select a 
display from the “ElitePIs Available” grid and then press the 
ADD button. 

Step 3: On the Upper Left side of the window under “Tasks”, select 
the “Display Time” and “Display Panel Address” options.  
When selected, the check boxes will be checked. 

Step 4: Press the OK button on the bottom of the screen to retain 
the results.   

 Note:  If for some reason you wish to not retain what was 
done then click on the CANCEL button. 

Step 5: After pressing the OK button the main editor window will be 
presented again.  It would be a good idea to save your work 
so File -> Save All from the bar menu to save all the data 
thus far to the database. 

4.4 Creating and Editing a Kit 

Now that we are back to the Main Editor window (Figure 3) and with a 
Task built we can now create a Kit.  Click on the NEW KIT button and 
new Kit window will be displayed (Figure 8). 

 

Figure 8 – New Kit Definition Window 

There are two pieces of information that need to be entered to create a 
kit and those are its name and description. 
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Columns Description 

Kit Name A 20 character unique name for the kit. 
Description 120 character verbose description of the Kit. 

 

Step 1: Fill in the Kit Name and its Description.  You must fill in both 
for them to be accepted.  To retain what was entered press 
the OK button which will return you back to the main editor 
window. 

Step 2: After you have entered the Kit information it is always a good 
idea to save it to the database. Select File -> Save All from 
the bar menu to save the data. 

Step 3: After saving, select the Kit from the drop down list box if it is 
not already selected. 

Step 4: Next the Task needs to be included into the Kit.  Drag the 
Task you created earlier from the Task grid and drop it into 
the “Tasks Assigned to a Kit” grid or you can select the Task 
in the “Tasks Available” grid and press the ADD TASK button. 

Step 5: After adding the Task save the information.  Select File -> 
Save All from the menu bar to save the data. 

4.5 Building a Kit 

Now that a Kit has been created it needs to be built and placed on the 
USB Flash Drive.  If you have not already done so, insert the USB drive 
into one of the computer’s USB ports.  Depending upon which version 
of Window you are using and if this is the first time the USB Flash Drive 
has been inserted, a number of windows or information balloons will be 
presented stating the drive is being recognized by Windows.  Allow 
those messages to finish.  If there are balloon messages appearing 
(Windows 2000 and Windows XP) they will stay present at the bottom 
of the screen, just acknowledge them by clicking on the “X” box in the 
upper right corner of the balloon.  If windows are presented, (Windows 
98SE) they will close once Windows installs the USB Flash Drive. 

It is quite easy to build a kit. 

Step 1: If the Kit you just created is not selected in the dropdown box 
select it now. 
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Step 2: In the Build Drive dropdown box, select the drive letter that 
was assigned to the USB Flash Drive from the list.  

 PLEASE NOTE:  Next to each drive letter will be the word 
Fixed or Floppy.  The USB Flash Drives are considered 
Floppy type drives. 

Step 3: After the drive is selected click on the BUILD KIT button.  If 
for some reason an installation kit already exists on the USB 
Flash Drive, a prompt will be presented asking if you wish to 
overwrite it.  Just acknowledge the prompt by clicking on the 
OK Button. 

Step 4: The Messages status bar will present information regarding 
the build process.  Eventually a prompt will be resented 
stating the build is completed.  Acknowledge the prompt by 
clicking on the OK button. 

Step 5: When the build is completed a prompt will be given.. 
Acknowledge the prompt by clicking on the OK button.  Once 
the green light is glowing steady on the Flash Drive it can 
probably be removed. 

 WARNING:  For Windows 98SE just remove the USB Flash 
Drive from the computer’s USB port.  For Windows 2000 and 
Windows XP, it is best that you instruct Windows to detach 
the drive.  In the System Tray on the Windows task bar is an 
icon on the tool bar (Figure 9) for performing that action. 

 

 

Figure 9 – Unload Device 

 

 Right click on the icon and a window will be presented with 
the USB devices currently connected.  Depending on your 
computer it could only be one entry or it can be a number of 
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entries.  Select the USB Flash drive you selected earlier o 
build the Kit on (same drive letter) and click on the STOP 
button.  Windows will take a second to remove the drive but 
will present a prompt stating that it has done so.  Click on the 
Ok button to acknowledge the prompt.  Then Click the Close 
button on the Unplug or Eject Hardware window.  Now you 
can remove the USB Flash Drive from the computer’s USB 
port.   

 If the drive will not disconnect, it will be necessary to close 
the USB Transfer Editor to release the drive. 

4.6 Your done!! 

Congratulations!!  You have built your first Kit.   Exit the USB Transfer 
Utility Editor, take the USB Flash drive to your displays and install your 
updated collection. 

5 Editor Features 

There are 9 screens within the ElitePI USB Transfer Utility Editor: 

 
Window Description 

Main Main window.   Provides access to all features in 
the application 

ElitePI Display Editor Allows for managing the Physical Addresses of 
each of the ElitePIs installed at your building. 

Task Editor Edits a specific Task that is defined in the Main 
Window Task Available grid. 

Kit Create Creates a new entry in the Kit dropdown box. 

Time HASP 
Configuration 

Configures the Time HASP.  Allows you to enter 
the password codes plus set the time and date 
on the HASP.  This is only available if you have 
installed the Time HASP drivers on the transfer 
computer and purchased the Time HASP 
feature. 

ElitePI Log View Allows the viewing of the ElitePI system log. .  
The log is stored on the USB Flash Drive. 
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Transfer Execution 
Log 

Allows the viewing of the execution log from a Kit 
that was executed on an ElitePI.  The log is 
stored on the USB Flash Drive. 

Transfer Command 
Processing Log 

Allows the viewing of the command execution 
log.  This is a breakdown of each command 
instruction executed for a Kit on an ElitePI.  The 
log is stored on the USB Flash Drive 

Build Error Log 
Allows the viewing of the Transfer Editor build log 
in the unlikely event that an error occurs when 
building a Kit to the USB Flash Drive. 

Recover Backup 
Allows for selecting a database backup to 
restore.  The database backup information is 
displayed by date of backup. 

 

This section will describe the windows and their purpose. 

5.1 Editor Main Window 

This is the window (Figure 3) that is presented when the USB Transfer 
Utility Editor is first started.  It provides the point where all other 
screens are activated from.  Most screen editors are typically activated 
from the bar menu at the top of the window but some features also 
have standard click buttons for convenience.    

5.1.1 Bar Menu 

The bar menu at the top of the window has 4 drop down menus (File, 
Edit, View and About) of which various editing features can be 
accessed.    The following will review each menu option. 

5.1.1.1 File Menu 

 
Option Description 

Build Transfer 
This option takes the current Kit selected in 
the Kit dropdown list and builds it to the USB 
Flash Drive selected in the Build Drive 
dropdown list. 
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Recover Backup 

Allows for selecting you of the 9 possible 
database backups available.  This is used in 
the unlikely event the database becomes 
corrupted or you saved a database from a 
previous editing session that you did not wish 
to keep. 

Save All Saves the entire database back to the 
database files.  All data is save at that time. 

Exit (No Save) 

This exits the USB Transfer Editor without 
saving any changes made on any of the 
screens.  This is used when changes were 
performed and a significant mistake was 
made which would negatively effect the 
configuration. 

Exit Saves all the data back to the database and 
closes the application. 

 

5.1.1.2 Edit Menu 

 
Option Description 

Displays Opens the ElitePI display configuration editor. 

Tasks 

Opens a sub-menu where you can select 
New:  A new row is added to the bottom of 
the Tasks Available grid.  
Edit:  Takes a currently selected task in the 
Tasks Available grid and opens the Task edit 
window for that Task. 
Delete:  Takes the currently selected task 
and deletes it. 
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Kits 

Opens a sub-menu where you can select: 
New:  Opens the Kit create window and 
allows you to add a new Kit.  The NEW KIT 
button provides the same functionality. 
Edit:  Opens the Kit edit window and displays 
the currently selected Kit in the Kit dropdown 
box.  Allows you to edit the Kit name and its 
description. 
Delete:  Deletes the currently selected Kit in 
the Kit dropdown. 
Save:  Saves the kit to the memory resident 
database.  This does NOT save it to the 
database file. 

HASP 
Opens the Time HASP configuration window.  
It allows the setting of the Date and Time on 
the Time HASP plus entering the Time HASP 
security code. 

5.1.1.3 View Menu 

 
Option Description 

ElitePI Log 

When a Task is configured to retrieve the 
ElitePI System logs this option allows you to 
open the log file for viewing.  The USB 
Flash Drive needs to be inserted and 
selected in the Build Drive dropdown box. 
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USB Execution Log 

When a Task executes on a display a log 
file of the ElitePI screen is saved and 
dumped to the USB Flash Drive once all the 
requested instructions in the Task have 
been executed.  This option allows you to 
view the log file.  The USB Flash Drive 
needs to be inserted and selected in the 
Build Drive dropdown box. 
 
Note:  In order to have unique log files 
created after the installer runs it will be 
necessary to not use the All Displays option 
in the Task.  Each display will need to be 
selected from the available displays and 
placed in the Execute On grid for the Task. 

USB Processing Log 

When a Task executes on a display a log 
file is created containing all the commands 
that where executed on the ElitePI.  This 
option allows you to view the commands 
executed log file.  See the Note above on 
the USB Execution Log for issues 
surrounding this log file. 

Build Error Log 
This option allows you to view the Build 
Error log file that is generated when a build 
error occurs. 

 

5.1.1.4 Help Menu 

 
Option Description 

About Describes this application 

 

5.1.2 Tasks Available - Editor Grid 

This grid manages the Task definitions.  Tasks can be manipulated 
from here using the following techniques: 
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• Using the buttons on the right side of the grid.  There are buttons 
to create (new), edit and deleted Tasks from the grid. 

• Using the window bar menu described in Section 5.1.1.2 to create 
(new), edit or delete Tasks from the grid. 

• Double clicking on a Task in the grid will open the Task editor or 
selecting it on the grid and pressing the EDIT TASK button next 
to the grid. 

Figure 6 shows the “Tasks Available” grid. 

5.1.3 Kits 

 

Figure 10 –Kit Selection Area 

Used to select a Kit that is going to be edited and used to select the 
Kit that will be built.  The 3 buttons to the right of the kits list allows 
you to Create, Edit or Delete a Kit.  To Edit or Delete a kit, the kit 
name must be selected in the dropdown list. 

5.1.4 Tasks Assigned to a Kit 

 

Figure 11 – Tasks Assigned Area 

This is used in conjunction with the Kits definition.   This grid 
maintains the list of Tasks that are assigned to the Kit selected in the 
Kits dropdown.  Tasks are selected in the “Tasks Available” grid and 



ElitePI USB Transfer Utility 
Version 1.0.0.12 
 

Page 22 

either dragged from there to this grid to populate it or the task can be 
selected in the “Tasks Available” grid and the Add Task button can 
be pressed to add the task to the Kit.  Tasks can be removed from 
this grid by either selecting the Task with the mouse and drag it off 
the grid or selecting the task and pressing the REMOVE TASKS 
button next to the grid.  Do not drag the Task off the editor Window; it 
will not be dropped if you do.  If you did the Quick Start Section you 
would have manipulated this grid in the exercise. 

5.1.5 Build Drive 

 

Figure 12 – Build Drive area 

This selects the disk drive where the Kit is to be saved.  Most of the 
time the Kit will be built on a USB Flash Drive but there are times 
where you need to build the Kit on a fixed disk drive (like the C drive).  
Select the drive in the dropdown list and press the Build Kit button to 
create a Kit.   After the Kit is constructed, it will be saved the selected 
disk drive. 

When building to a fixed disk drive it is probably because the USB 
Drive is not currently available.  When a fixed disk drive is selected it 
will write the Kit to the root directory of that drive.  The package name 
is named “USBInstaller.zip”.  It is possible to e-mail this file so that it 
can be placed in the root directory of the USB Flash drive for 
installation at another location. 

5.2 ElitePI Display Editor 

This window manages the configuration of the ElitePI Physical address 
information.  The window (Figure 4) consists of an editing grid and 4 
buttons to manipulate the editor.  This editor was discussed in the 
Quick Start Guide in Section 4.  So a brief description will be provided 
here for the features on this window. 
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5.2.1 Displays – Grid 

This contains the display configuration information. 

5.2.2 OK – Button 

When clicked retains the information entered, closes the editor and 
returns to the Main application window. 

5.2.3 Cancel – Button 

When clicked it does NOT retain any of the information entered, 
closes the editor and it returns to the Main application window. 

5.2.4 Add – Button 

When clicked adds a row to the bottom of the grid list and positions to 
the first editable column in the row. 

5.2.5 Delete – Button 

When clicked deletes the selected row in the grid. 

5.3 Task Definition Editor 

Figure 7 in Section 4 shows the Task Definition window.  As stated 
earlier, it is a busy window with lots of configuration options available. 

The window is broken up into 4 sections which are listed below. 

 
Option Description 

Tasks 

Describes specific actions to perform on a 
display.  These would be retrieve a previous 
collection, display information (time / date / 
panel address) and retrieve the application 
logs 

Time and Date Techniques to reset the ElitePI time and date 

Install and Execute 
Program 

Selecting an ElitePI collection to update the 
ElitePI or a program that C.E. Electronics 
provided that can be executed on an ElitePI 
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Displays 
A list of available displays that have been 
configured in the editor and the list of displays 
that this Task is going to be executed on. 

5.3.1 Tasks 

 

Figure 13 – Task Definition window Tasks area 

These are instructions you can give to the USB Installation program 
when it executes on an ElitePI.  They are checkbox type options that 
can be clicked on to select them.  When selected they will have a 
check mark in the box next to the item.  There are 9 options to 
choose from: 

 
Option Description 

Get Current Collection Retrieves the currently active collection 
on the ElitePI. 

Get Previous Collection Retrieves the previous collection from 
the ElitePI. 

Get Old1 Collection Retrieves the 2nd oldest collection from 
the ElitePI 

Get Old2 Collection Retrieves the 3rd oldest collection from 
the ElitePI 
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Get System Logs 
Retrieves the ElitePI software log.  This 
will be copied to the USB Flash Drive 
and can be viewed in the ElitePI log 
viewer 

Get ElitePI Time/Date 

Displays the Time and Date the ElitePI is 
set at.  This is displayed when the 
installation utility executes on the ElitePI.  
This can also be viewed in the Execution 
Log that was copied back to the flash 
drive. 

Get ElitePI Physical 
Address 

Displays the ElitePI Physical Address set 
on the rotary switches on the ElitePI 
computer when the installation utility 
executes on the ElitePI.  This can also 
be viewed in the Execution Log that was 
copied back to the flash drive. 

Test Collection 

If a new or updated collection is being 
applied sometimes it is useful to review 
test the collection after installation.  
Setting this option will restart the ElitePI 
software and allow for viewing the 
new/updated collection.  It will stay active 
for about 10 seconds before proceeding 
on with completing the installation script. 
NOTE:  This need for this feature is now 
obsolete and is no longer necessary but 
is still available for selection and will still  
execute on the ElitePI display. 

Reboot ElitePI 
There are times when it will be 
necessary to cold boot the ElitePI.  This 
option allows you to do that. 

 . 
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5.3.2 Time and Date 

 

Figure 14 – Task Definition window with the Time and Date area 

The Time and Date section provides options to modify the time and 
date on the ElitePI.  There are 3 methods available to do this with: 

 
Method Description 

Time HASP 

This option can be used if the Time HASP 
option was purchased.  It allows you to set 
the time on a special USB HASP device that 
contains a real time clock.  The date and 
time are both set when using this option. 

Absolute 
This option is available when it is necessary 
to set the date and/or time to fixed value.  
This is can be set individually for both the 
date and/or time. 

Offset 

This option is used when the ElitePI is 
behind or ahead of time by a finite amount 
and it necessary to push the time a certain 
amount of time (hours / minutes / seconds) 
or the date by a certain number of days.  
This is available individually for setting the 
date and/or time. 



ElitePI USB Transfer Utility 
Version 1.0.0.12 
 

Page 27 

 

5.3.2.1 Time HASP method (optional feature) 

Using this method the Time HASP will set both the date and time.  It 
is required while at the ElitePI that you insert the USB Time HASP 
into the ElitePIs USB port while the installation utility is running.  
Follow the directions that are displayed on the ElitePI.  You will be 
instructed when to insert the Time HASP and when to remove it.  
You must have access to the screen to see the message appear 
while the Kit executes. 

5.3.2.2 Time and Date Absolute Method 

When selecting the Time or Date checkbox you are provided with an 
option on what method (absolute or offset) to use to set the ElitePI 
time and date.  The absolute method allows setting a FIXED value 
for the date or time.  When absolute is selected the absolute 
combination boxes are activated. 

When setting time use the mouse to select what part (hour, minute 
or second) of the time you wish to adjust.  The rotors can be 
manipulated by clicking on the upper part of the rotator to move the 
time back or clicking on the bottom part of the rotator to move the 
time forward.  For the date, clicking on the arrow will open a date 
selection calendar to allowing for browsing through the calendar to 
select a date. 

5.3.2.3 Time and Date Offset Method 

The offset method allows for setting an offset time and date to the 
current time and date on the ElitePI.   The time can be setup by the 
hour, minute and second and the date by the number of days.  The 
time offset on the ElitePI will be added too or subtracted from the 
current time or date. 

For example, if the current time on the ElitePI is 10:11am and you 
wish to increase the time by 10 minutes and 20 seconds then the 
following would be set in the offset time selector boxes.   Select 
direction indicator to and set it to “+”, leave the hours set to “0”, set 
the minutes to “10” and set the seconds to “20”.  When this 
instruction is executed via the USB Installer it will add 10 minutes 
and 20 seconds to the current time on the ElitePI. 
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To move the date ahead you can specify the offset in days.  The 
day can be pushed forward up to 10 days.  So if the date is January 
31, 2004 and the date is really February 1, 2004 the day needs to 
be pushed forward 1 day.  Set the day offset direction to “+’ and the 
day offset to “1”.  When executed by the USB Installer the date will 
be pushed ahead 1 day and change the date to February 1, 2004.  
Remember this is relative to the current date of the ElitePI. 

This feature will typically be used in areas that need to adjust their 
clocks to adhere to Daylight Savings Time. 

5.3.2.4 Install Collection and Execute Program 

 

Figure 15 – Task Definition window Install and Execute files selection 

The Install collection feature will probably be the most used function 
of the USB Transfer tools that are available since it will allow for the 
updating of the ElitePIs collection.  Execute Program will allow you 
to install a program and run it on the ElitePI.  Usually this will be 
used when a new driver or codec needs to be installed on the 
display 

PLEASE NOTE:  Only use this option with C.E. Electronics 
provided executables.  Using non C.E. Electronics executables 
could damage the ElitePI and may require it to be returned to 
the factory for repair. 

To install a collection press the SELECT button next to the 
“Collection To Install” edit box.  This will present a file browser 
dialog that will allow for moving in directories to locate a collection 
.zip file.  Make sure you choose an ElitePI collection file.  When 
found select the file and the information will be deposited in the edit 
box.  There is an attempt to determine if you selected a good file but 
it is NOT absolutely full proof. 



ElitePI USB Transfer Utility 
Version 1.0.0.12 
 

Page 29 

To select an executable to run on the ElitePI, press the SELECT 
button next to the “Program to Execute on Elite PI’ edit box.  A file 
browser dialog will be displayed allowing for moving in directories to 
locate an executable .zip file.  When the desired file is found select 
the file and the information will be deposited in the edit box.  If you 
fail to select a C.E. Electronics provided utility an error will be 
displayed. 

5.3.3 Displays 

 

Figure 16 – Task Editor Displays Selection Area 

To select the ElitePI(s) that the Task is to be executed on you need to 
select the ElitePI from the “ElitePIs Available” grid and put it in the 
“ElitePIs Task Are To Be Executed On”.  The “ElitePIs Available” grid 
contains the available ElitePIs entered into the “Display Editor” 
window described earlier, and the “ElitePIs Task Are To Be Executed 
On” grid, will contain which displays this Task is assigned to.  The 
“Task Scope” defines how these two grids are used. 

The Task scope allows you to select only 1 of the 2 settings 
presented: 

 
Task Scope Description 

All ElitePIs All ElitePIs will execute this Task 

Only Specific ElitePIs 
Only the ElitePIs selected in the “ElitePIs 
Task Are To Be Executed On’ grid will 
execute the Task. 

 

When the “Task Definition” editor is presented for a new Task, the 
“Task Scope” is set to “Only Specific ElitePIs”.  This allows for 
dragging entries from the “ElitePIs Available” grid and dropping them 
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to the “ElitePIs Task Are To Be Executed On” grid or selecting the 
ElitePIs name on the “ElitePIs Available” grid and pressing the ADD 
button.  If you choose to change the scope to “All ElitePIs” the grids 
will become inactivated and cleared.  Care should be taken when 
setting the “Task Scope”. 

PLEASE NOTE:  The ElitePI can only be added once.  If it is 
duplicated an error message will be displayed. 

5.4 Kit Create 

The Kit Create windows as shown in Figure 8 in Section 4 is opened 
when a user selects the Edit -> Collection -> New from the Main 
window bar menu or by pressing the NEW KIT button next to the Kit 
combo box. 

There are two items that need to be filled in to create a new Kit and 
those are: 

 
Item Description 

Kit Name This is a 20 character unique name for the kit. 
Description Verbose description of the Kit. 

 

Fill in these two items and press the OK button and the Kit will be 
added.  If you change your mind you can press the CANCEL button 
which will close the window and discard the information entered. 

5.5 Time HASP Configuration 

Figure 5 in Section 4 shows the optional feature window which 
provides a way to update the ElitePIs date and time via a real time 
clock built into a USB HASP.  It provides a convenient way to update 
the ElitePI time/date during the execution of a kit on an ElitePI. 

The window is broken down into 3 sections: 
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Section Description 

Pass Code 
The Time HASP is password protected and 
requires the two Pass Codes to be entered 
in order to set the time/date and to access 
the time/date. 

Set To The time and date the Time HASP will be 
set to when the SET button is pressed. 

HASP The time and date the Time HASP is 
currently set to. 

 

Insert the Time HASP into an available USB port and from the bar 
menu select Edit -> HASP.  When the window is initially opened it 
looks for the Time HASP.  If it can not find it,  the window except for the 
being able to enter a pass code and activating it.   

The pass code must be entered in order for the window to locate and 
communicate with the Time HASP.  Enter the pass code provided with 
the time HASP.  Make sure you fill in both pass code entry boxes   
Make sure the Time HASP is inserted into a USB port on the computer 
and click on the FIND button.  If the pass code was entered correctly 
then the “HASP” area of the window will be go active and the SET 
button will be turned on.  Also the pass codes will be added to the 
memory resident database. 

To set the time on the Time HASP the “Set To” section needs to be 
adjusted to the desired date and time.   In addition to the edit boxes for 
the time and date there is a check box that keeps the time and date 
edit boxes in sync with the current computer time.  If the computer time 
is not desired to be applied to the Time HASP then uncheck this box 
and adjust the time and date to the desired values.   When ready, click 
on the SET button and the time/date on the Time HASP will be 
adjusted and represented in the “HASP” area of the window. 

5.5.1 OK Button 

When clicked closes this window. 

5.5.2 SET Button 

When clicked sets the time and date on the Time HASP based upon 
what the time and date edit boxes are set to in the “Set To” area. 
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5.5.3 FIND Button 

Locates the Time HASP and if found enables the ”HASP” area of the 
window which keeps the time and date boxes in the window 
synchronized with the Time HASP.   

PLEASE NOTE:  The Time HASP must be inserted into a USB 
port on the computer and the pass code must be correctly 
entered in the pass code boxes for the window to be able to 
access the Time HASP. 

5.5.4 STOP / START Button 

Disables keeping the time and date edit boxes in sync for both the 
Set To (if the system time checkbox is checked) with the computer 
time/date and the HASP section time and date edit boxes being kept 
in sync with the Time HASP.  To re-establish synchronization the 
STOP button will become the START button.  Pressing the START 
button will restart time/date synchronization. 

PLEASE NOTE:  The SET button is disabled when 
synchronization is stopped.  

5.6 ElitePI Log View 

This window is used to review the retrieved log file from an ElitePI.  To 
view the log the following must have been done. 

• Get System Logs Task checked in the Task definition. 

• The ElitePI display needs to be selected in the Task. 

PLEASE NOTE:  If the “Task Scope” was set to “All ElitePIs” then 
the log files will not be saved for each individual ElitePI.  The 
ElitePIs need to be individually selected.   The system log saved 
will be from the last ElitePI updated. 

• The Task needs to be in the Kit and the kit needs to be executed 
on the ElitePI. 

If the above is true then the ElitePI system log will be present on the 
USB Flash Drive.  To access the log file from the USB Flash Drive 

• Insert the USB Flash Drive into an available USB port on the 
computer 
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• On the Main window select the drive in the Build Drive dropdown 
box. 

• On the Main window menu bar select View -> ElitePI Log. 

The window in Figure 17 will be presented: 

 

Figure 17 – ElitePI Log viewing window 

The window is broke up into a large display area where the log file 
contents are displayed and a dropdown box that contains the name of 
the ElitePI that has a log file on the USB Flash Drive.  Selecting an 
ElitePI from the dropdown box will cause the log file for that ElitePI to 
be loaded and displayed. 
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5.6.1 CLOSE Button 

Closes the window.  

5.7 Transfer Execution Log 

This window is used to review the retrieved execution log file generated 
when USB Installer is on the ElitePI.  To view the log the following must 
have been done. 

• The ElitePI display needs to be selected in the Task 

PLEASE NOTE:  If the “Task Scope” was set to “All ElitePIs” then 
the log files will not be saved for each individual ElitePI.  The 
ElitePIs need to be individually selected.   The system log saved 
will be from the last ElitePI updated. 

If the above is true then the Execution log will be present on the USB 
Flash Drive.  To access the log file from the USB Flash Drive 

• Insert the USB Flash Drive into an available USB port on the 
computer 

• On the Main window select the drive in the Build Drive combo box. 

• On the Main window menu bar select View -> USB Execution 
Log. 

The window in Figure 18 will be presented: 
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Figure 18 – Transfer Execution Log window 

The window is broke up into a large display area where the log file 
contents are displayed and a dropdown box that contains the name of 
the ElitePI that has a log file on the USB Flash Drive.  Selecting an 
ElitePI from the dropdown box will cause the log file for that ElitePI to 
be loaded and displayed. 

5.7.1 CLOSE Button 

Closes the window.  
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5.8 Transfer Command Processing Log 

This window is used to review the retrieved command processing log 
file generated when USB Installer is on the ElitePI.  To view the log the 
following must have been done. 

• The ElitePI display needs to be selected in the Task. 

PLEASE NOTE:  If the “Task Scope” was set to “All ElitePIs” then 
the log files will not be saved for each individual ElitePI.  The 
ElitePIs need to be individually selected.   The system log saved 
will be from the last ElitePI updated. 

If the above is true then the Execution log will be present on the USB 
Flash Drive.  To access the log file from the USB Flash Drive 

• Insert the USB Flash Drive into an available USB port on the 
computer 

• On the Main window select the drive in the Build Drive combo box. 

• On the Main window menu bar select View -> USB Processing 
Log. 

The window in Figure 19 will be presented: 
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Figure 19 – Processing Log viewing window 

The window is broke up into a large display area where the log file 
contents are displayed and a dropdown box that contains the name of 
the ElitePI that has a log file on the USB Flash Drive.  Selecting an 
ElitePI from the dropdown box will cause the log file for that ElitePI to 
be loaded and displayed. 

5.8.1 CLOSE Button 

Closes the window.  
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5.9 Build Error Log  

This window is used to review the build log file generated when a Kit is 
built on a Flash Drive. 

To access the log file from main window menu bar select View -> Build 
Log. 

The window in Figure 20 will be presented: 

 

Figure 20 – Build Error Window 

The window is broke up into a large display area where the log file 
contents are displayed.  When the window is opened the current build 
log file is loaded and displayed. 
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5.9.1 CLOSE Button 

Closes the window.  

5.10 Recover Backup 

This window allows for the selection of a database backup to restore.  
A dropdown box is presented with the possible backups to restore from 
based upon the date of the backup. 

 

Figure 21– Recover Backup Window 

Select a backup from the list and press the RESTORE button.  A 
message will be presented asking if you are sure about this action.  
Press the YES button to restore the backup or NO to abort.  The 
window will close when completed. 

5.10.1 RECOVER Button 

When pressed looks at the selected backup in the dropdown box, 
replaces the current database with the backup and activates it. 

5.10.2 CANCEL Button  

Closes this window WITHOUT any recovery operation being 
performed. 
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Appendix-A Setting the Physical Address 

To set the physical address you must have access to the computer board 
mounted on the back of the ElitePI  You must know up front, what the 
physical address needs to be set to before going to the ElitePIs and setting 
them. 

It is HIGHLY advisable that you contact your elevator service contractor or 
C.E. Electronics for further assistance in defining the physical addresses 
before proceeding.  Only your elevator service contractor should perform 
these setting changes on the computer board. 

 

Figure A-1 – View of dipswitch and rotaries 

Once all the physical addresses have been identified for the ElitePIs in your 
building or campus, go to each ElitePI and set the addresses.  If the ElitePI is 
installed, take the necessary precautions before proceeding with removing the 
ElitePI from the elevator (safety and elevator power).  Using Figure A-1, 
locate the two rotary switches on the ElitePI driver board.  There are two 
rotary switches, one for the low address (Switch S3) and the other for the high 
address (Switch S2).  Note that the rotaries are labeled in hexadecimal 0-F 
which is equivalent to 1 – 16 in the USB Transfer Editor’s Display Editor 
screen (See Section 4.2.1).  Using a flat blade screw driver, turn the rotaries 
carefully to the designated address.  To verity they are set to the correct 
address set switch 1 on the dip switch to the “on” position.  This will place the 
display in demo mode and show a diagnostics screen where the rotary 
information is display at the bottom section of the window.  The Brightness 
indicator is the high address rotary (Switch S2) and the Address indicator is 
the low address rotary (Switch S3).  Please note that the values for Switch S2 
are represented here as 0 – F and the values for Switch S3 are represented 
here as 0 – 15. 

INFORMATIONAL NOTE:  In earlier versions of the ElitePI, Switch S2 was a 
hardware brightness control for the display screen.  It is no longer used as a 
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brightness control mechanism.  It is now designated the physical high address 
rotary. 

Once the address is set correctly, set switch 1 of the dip switch to the “off” 
position and check for proper operation.
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